Broadband Internet outage
Incident Report for Trustpower
Resolved
This issue has now been resolved. Please call us on 0800878787 if you are still experiencing any issues after powering off your modem for 20 seconds and waiting 2-3 minutes. Thank you
Posted Nov 21, 2017 - 17:10 NZDT
Identified
We are currently aware of a small number of broadband customers nationwide experiencing issues connecting to the internet.
Customers will have a red PPP or WWW light on their modem.
We are working to resolve this as quickly as possible and apologise for any inconvenience.
Posted Nov 21, 2017 - 16:42 NZDT