Nationwide Outage
Incident Report for Trustpower
Resolved
Service has now been restored to all customers who were impacted as part of this outage.

If problems persist please contact our Technical Support Team on 0800 87 87 87 or our webchat team at www.trustpower.co.nz
Posted Dec 04, 2017 - 08:32 NZDT
Investigating
We are currently aware of an outage impacting some Broadband and Ultra Fast Broadband Customers.

Customers may be experiencing issues connecting to, or browsing the internet. Ultra Fast Broadband Customers may also experience issues making and recieving calls.

We are currently investigating this with the highest priority, and we apologise for any inconvenience caused.
Posted Dec 04, 2017 - 07:24 NZDT