Ultra Fast Broadband Outage
Incident Report for Trustpower
Resolved
Service has now been restored to all customers who were impacted as part of this outage.

If problems persist please contact our Technical Support Team on 0800 87 87 87 or our webchat team at www.trustpower.co.nz
Posted Nov 15, 2017 - 20:00 NZDT
Investigating
We are currently aware of an outage impacting Ultra Fast Broadband customers in the Palmerston North area.

Customers may be experiencing issues connecting to, or browsing the internet as well as being unable to make and receive calls due to an outage at the local exchange.

This is currently being worked on with the highest priority.
Posted Nov 14, 2017 - 19:36 NZDT