Copper Broadband Outage
Incident Report for Trustpower
Resolved
This incident has been resolved.
Posted Aug 22, 2017 - 08:16 NZST
Identified
We are currently aware of an outage impacting customers in the Far North region.

Customers may be experiencing issues connecting to, or browsing the internet due to a fibre cut.

This is currently being worked on with the highest priority.
Posted Aug 21, 2017 - 12:35 NZST