Wellington Ultra-Fast Broadband Outage
Incident Report for Trustpower
Resolved
Service has now been restored to all customers who were impacted as part of this outage.

If problems persist please contact our Technical Support Team on 0800 87 87 87 or our webchat team at www.trustpower.co.nz
Posted Oct 20, 2017 - 13:09 NZDT
Investigating
We are currently aware of an outage impacting customers in the Wellington region.

Customers may be experiencing issues connecting to, or browsing the internet.

This is currently being worked on with the highest priority.
Posted Oct 20, 2017 - 12:52 NZDT