Trustpower Domain Service Webmail
Incident Report for Trustpower
Resolved
This issue has now been resolved.

If problems persist please contact our Technical Support Team on 0800 87 87 87 or our webchat team at www.trustpower.co.nz
Posted May 22, 2017 - 14:25 NZST
Investigating
We are currently aware of a fault impacting Webmail services for customers who have a Domain Email Service that is supplied via Trustpower

Customers will still be able to check their emails on their client emails using Outlook, Mac Mail, etc but will be unable to login using the Webmail Service and may receive an error stating an incorrect Username and Password was entered.

This is currently being worked on with a high priority and we apologize for any inconvenience.
Posted May 22, 2017 - 13:20 NZST