Fibre Internet - Nationwide
Incident Report for Trustpower
Resolved
This issue has now been resolved.
If you are still experiencing connection issues please power off your modem for 2-3 minutes and then wait 2-3 minutes for it to connect.
Thank you.
Posted Sep 25, 2018 - 11:01 NZST
Investigating
We are currently investigating a small number of Ultra Fast Fibre customers nationwide who are experiencing issues connecting to or browsing the internet.
We are looking into this ASAP and appreciate your patience during this time.
Posted Sep 25, 2018 - 09:18 NZST